Skip to main content
System StatusContact Support
VersionOne Community

OTA version is not compatible

Problem

After attempting to run the VersionOne/Quality Center integration, there is an "OTA version is not compatible"  error.

After upgrading a Quality Center instance or after using a browser (Internet Explorer) that was previously used to open an older version  of Quality Center, you might experience a class of errors that are related to the incorrect OTA when running the integration with a newer instance.  OTA refers to the Quality Center API (Open Test Architecture).  When you browse to your Quality Center instance for the first time, some dlls are downloaded to location Program file > Common Files > Mercury Interactive > Qualty Center.  After executing the VersionOne.Servicehost.exe, the process loads the OTA dll and makes an attempt to connect to Quality Center but throws an exception since the OTA is out of date.

The console errors look similar to this:


Failed to execute QualityCenter connection validation

System.Runtime.InteropServices.COMException (0x80047535): OTA version is not compatible with the Application Lifecycle Management server

Solution

Fefresh the OTA  libraries.

  1. Open a browser and go to Quality Center on the machine that you are trying to run the integration on. 

  2. If you have a url like "http://hpmercury10:8080/qcbin/start_a.htm" to access Quality Center, cut off the "start_a.htm" to get the screen that you need to be on. 

  3. Click Add-Ins Page

  4. Then click HP Quality Center Connectivity to install.

  5. Rerun integration