Skip to main content
System StatusContact Support
VersionOne Community

VersionOne Setup in Continuum

Overview

For Continuum to communicate with the web service we must first setup the connectivity.

Networking Requirements

Continuum will need outbound access to the VersionOne servers on whatever port VersionOne is setup to listen on (typically ports 80 or 443). The VersionOne  server will need inbound access from Continuum on the same port. Continuum may also need inbound access on port 8080 from VersionOne. This is needed if you will be using the VersionOne DevOps center.

Configure the VersionOne Plugin

  1. In the Continuum UI, upper right menu, select Administration -> Manage Plugins. Select VersionOne on the left and fill in the appropriate values.

  2. The Name field is an arbitrary name for this instance.

  3. API Token will be an Access Token for a user in VersionOne. This user will need the proper permissions to be able to query the API and the projects that are necessary.

  4. For more information on generating API Access Tokens in VersionOne, see the VersionOne Community site. Be sure to select Access Token, not OAuth2.

  5. The URL will need to include the protocol and port if not port 80 or 443 (https).

  6. If using hosted VersionOne, the URL will be in the following format.

  7. Make sure to check the Is Default? box.

  8. Once you step off of each input field of the plugin form, the information that is entered will Auto Save (You should see a pop-up with a green check mark in the top right of the browser).

Test Connectivity

Click on the Test Connection button to test the connection to VersionOne.

Possible responses from the page:

  • "SUCCESS: Connected to VersionOne at address..." - all is well

  • "Connection refused" - wrong port or address was used

  • "VersionOne server did not accept the credentials provided" - user id or password is wrong

  • "Operation timed out" - a timeout, wrong port, address or firewall issue

  • "nodename nor servname provided, or not known" - wrong address or DNS issue

  • "VersionOne plugin is not configured properly" - credentials and address worked, but VersionOne isn't responding properly. Contact support@versionone.com.

Next

Return to Connecting to Tools.

  • Was this article helpful?